Back to overview
Resolved

Road Billing Services Offline

May 29, 2026 at 5:02am UTC
Affected services
Docs

Resolved
May 29, 2026 at 6:08am UTC

Issues resolved

Created
May 29, 2026 at 5:02am UTC

Power/Cooling issues in Azure West US 2